Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Greek alphabet vowel characters with
Greek alphabet vowel characters with dieresis are not displayed correctly, for example unicode characters 970 (ϊ) and 971 (ϋ) are displayed as 943 (ί) and 973 (ύ) respectively. No problem with Please advise.

On my PC displays correctly everywhere. Tested in QM code, output and list of macros.
In this version changed font in list of macros and other tree view controls. Maybe the font does not support these characters. Previously was a hardcoded font, don't remember which, now is system default font for tree view controls (icon font).
When I try to key such characters (for example using notepad) although I key correctly the character is displayed erroneous.
Is QM in Unicode mode? Options -> General -> Unicode.
Certainly yes.

I will test it on another PC in a coulpe of hours and I will let you know. Let me repeat : no problem with I shifted back to it and I cross-checked twice.

Here works too. I used this code to test:
Macro (ϊ)
Copy      Help
act "Notepad"
key "970 (ϊ) and 971 (ϋ) are displayed as 943 (ί) and 973 (ύ)"

How this works?
Macro (ϊ)
Copy      Help
key (0x40000|970) ;;ϊ
Correct, OK.
I cannot reproduce this.

What is your key test macro?
What is keyboard layout/language?
What Windows version?
Dear Gintaras,

I tested on a second PC the error is reproduced.

I am sorry, I do not understand "Waht is your key test macro"? As I explained previously I type in a notepad or MS-Word window and altough I type the correct key for a vowel with dieresis, the dieresis is not displeyed when in

Keyboard layout/Language : English-US / English-US/Greek

XP 5.1 (SP3)

Anyway, I shifted back to and I presume I will stay there until the problem is corrected, perhaps in a new release.

Best regards

I thought it was with key() command.
If it happens when you type manually, the reason is probably TS menu triggers. If you can live without TS menus, disable TS menu in Options -> Triggers, until it will be fixed.
What keys you have to press to produce ϊ ?
Shift+; i

Now I can reproduce. Will fix it in next version, thank you.
I am sorry I have not explained the problem exactly. Many thanks for the solution advised : Yes, the problem is TS menu triggers. I can live without them. The keys I have to press are (Greek keyboard) :

Was easy to fix it. Will upload next QM version tomorrow, maybe today.
With current version it also will happen when recording, if "text" checked.
Forgot to say, after disabling TS menus need to restart QM.
Many thanks for this additional explanation. As reported earlier this afternoon, I disabled TS menu triggers, restarted QM and working perfectly. Regards.
Many thanks, with it is perfect. Regards.

Forum Jump:

Users browsing this thread: 1 Guest(s)