Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
problems running functions from code

I have some problems since I updated to v. Running macros and functions from the Run button works OK, but when I run the same functions from code from within a main macro, some of the functions won't start... In that case the main macro just hangs, no error message, nothing. It all worked fine before I updated.

Even stranger: Some functions, when run from code, are called again when returned to the main macro (so the function is called once but runs twice...!?) In other cases, when returned from the called function, the next function in the list is run without being called from the code. And finally, with some functions, after they return to the main macro, I get Error (RT) in Function: item not found.

It looks like the indexing of function lists in the qml file is wrong, so I created a new qml file and imported all macros and functions, but the problems remain the same. Any ideas what to do?


Please post code to test.
Sorry Gintaras, I solved the mistery.... I had inserted the mac command to run the functions in separate threads, but forgotten to put the function names in double quotation marks. (It must have been late :? ) Apparently, this caused the irratic behaviour. Now it works fine again. Sorry for the false alarm.


Forum Jump:

Users browsing this thread: 1 Guest(s)